High severity system failing.

Incident Report for Endless

Resolved

Clerk experienced performance degradation issues that are now resolved.
Posted Sep 15, 2025 - 13:54 GMT-03:00

Investigating

Authentication is failing.
Posted Sep 14, 2025 - 02:15 GMT-03:00
This incident affected: App and API.